Archive for » août, 2008 «

Les plus belles pannes de PC, sont celles que l’on provoque


Ce petit Billet est à l’attention de ceux qui « bidouillent » leur PC afin d’en améliorer le fonctionnement

Voilà, Samedi dernier, le 2 Août 2008, je me suis dit, depuis que je veux le faire, je vais le faire.
J’ai un PC fixe avec un Disque dur de 80 Go, avec 2 partitions.

A l’aide de Partition Magic, j’ai voulu agrandir la partition C, au détriment de la partition D, classique, normalement. J’ai d’abord réduit la partition D : et j’ai ensuite agrandi la partition C :, tout semble s’être bien passé, mais je ne peux plus booter sur mon disque C.
J’ai juste droit au curseur clignotant.
L’angoisse commence à m’envahir.

Je relance Partition Magic, je vérifie mes 2 partitions, tout semble OK, j’ai bien une « partition principale active » et une « seconde logique ».
Je tente une réparation à l’aide du CD de Windows XP, sans résultats, j’ai toujours le curseur clignotant.
Comme j’ai un CD « Ultimate Boot », je le lance et j’essaie de booter sur la 1ère partition, que nenni.
J’essaie sur la seconde, ça démarre, je me dis que je suis sauvé, mais là, grosse surprise, il continue l’installation d’XP commencée plus haut.
Je précise et vous verrez que c’est très important, le CD d’XP n’est plus dans le Lecteur.

Je me dis que ça semble bien parti quand un message que je n’avais encore jamais eu au cours de mes nombreux dépannages apparaît :
« Le fichier ‘asms’ du CD du Service Pack2 pour Windows XP Professionnel est nécessaire.
Entrez le chemin d’accès au fichier, puis cliquez sur OK.
Le chemin indiqué est I/I386, je fais OK, il ne se passe rien et pour cause, le CD d’XP n’est pas dans la machine (me dis-je).
Je mets le CD d’XP en place, clique sur le Bouton OK et j’attends, j’attends, on dirait que ça fonctionne, mais ce qui m’intrigue, c’est que le temps restant est bloqué à 39mn.
Bon, après de longues mn à attendre, je me dis que ça n’est pas la solution et je commence à désespérer.

En fait, en résumé, au boot du PC, il ne voit pas la partition C et lors d’une tentative de réparation à l’aide du CD d’XP, il me dit qu’il ne trouve pas le bon fichier sur le CD.

Bon, il faut tenter une réparation à l’aide de la console du même nom.
Une fois en mode console, je tape la formule magique :
« FixMbr » et là, j’obtiens un message énigmatique à la sauce Microsoft :
« FixMbr peut endommager vos tables de partition, si vous continuez, cela peut empêcher l’accès à toutes les partitions du disque en cours. Si vous n’avez pas actuellement de problème d’accès au disque, arrêter vous là.
Voulez vous vraiment écrire un nouveau secteur de démarrage (MBR) ? »

J’hésite et me dis qu’au point où j’en suis, je ne risque plus rien, puisque justement, j’ai un problème d’accès au disque et aux partitions.
Je clique sur Ok, un peu angoissé tout de même (J’ai un paquet de trucs que je ne voudrais pas perdre pour rien au monde sur ces 2 partitions), dans la foulée, je lance la seconde commande magique, à savoir : « FixBoot »
et et …
Surprise, le PC reboote tout seul comme un grand.
J’ai la barre de progression sur fond blanc et le logo d’Xp s’affiche, je me crois sauvé …………..
J’ai tort, je n’en ai pas encore terminé avec cette machine que j’ai contrariée dans ses habitudes.
J’ai droit au message suivant :
« Partition Magic de PowerQuest pour Windows NT/2000/XP est complet » (Je suis content),
mais il reprend l’installation de Windows XP, là où il en était.
J’avoue que pour l’instant, tout ça est un peu confus dans ma tête …….. Et tout d’un coup, j’ai droit au message ci-dessus, me disant qu’il me manque le fichier « asms ».

Perplexe, je me dis que « Google est mon ami » et à l’aide d’un autre PC, je fais une recherche sur Internet et découvre, que je ne suis pas le premier à avoir eu ce message énigmatique.
En fait, la solution est très simple à mettre en oeuvre (quand on la connaît), il faut remettre le CD d’XP dans le lecteur avant que le PC ne démarre et le message n’apparaït plus.
C’est magique.
En fait quand on met le Cd au moment où on a le message, c’est trop tard, il ne le lit plus, subtilité de l’informatique.
En réfléchissant, mon erreur a été de vouloir modifier la partition principale à l’aide de Partition Magic, alors que Windows était actif sur cette partition.
J’aurais dû le faire avec les disquettes de sauvegarde en mode « Dos », et mes partitions ont été inversées, sûrement dans le fichier « Boot.ini ».
C’est pour ça que « Ultimate Boot », m’avait permis de démarrer sur la 2ème partition parce que son numéro d’ordre dans ce fichier avait changé. (Pourquoi ?, mystère)

Bien sûr, il y avait la solution de facilité, à savoir tout formater et tout réinstaller.
Non seulement, je n’aime pas ce genre de dépannage, que certains appellent la maladie de « la formatite aigue », mais j’aime bien trouver le pourquoi du comment, d’autant que, quand je pense au boulot pour réinstaller mon PC, il valait sûrement mieux se faire travailler les méninges, même si j’ai mal dormi la nuit qui a suivie ……..

Bien sûr, j’ai eu quelques ennuis complémentaires pendant la réparation d’XP, certains fichiers de type « dll » manquaient et étaient introuvables.
Voulant terminer le processus, je les ai ignoré et l’installation s’est bien terminée.
Au reboot du PC, j’ai constaté que je n’avais plus Internet Explorer 7, que je n’avais plus le Pack SP3 (normal, mon CD ne le contient pas), que mon Imprimante ne fonctionnait plus et mon Logiciel de gravure non plus.
Pour le Logiciel de gravure et pour l’imprimante, pas de problême, une réinstallation a tout remis en ordre.
Par contre, je ne pouvais plus accéder à « Windows Update » pour faire des mises à jour de Windows XP, Pack SP3, Internet Explorer7 etc …
Une fois de plus, « Google » ma sauvé la vie, j’ai trouvé l’info sur Internet :

Description du problème :
« Cette erreur peut se produire si les services « WUAUSERV » et « BITS », ne sont pas correctement configurés dans le Registre (ça ne s’invente pas).

Résolution :
Ajouter WUAUSERV et BITS au processus SvcHost.
Cliquer sur démarrer.
Choisissez Exécuter.
Dans la boîte de dialogue Exécuter, entrer REGEDIT.
Cliquer sur OK.
L’Editeur de registre apparaît.
Affichez la clé suivante : HKEY_Local_Machine\Software\Microsoft\Windows NT\Current version\SvcHost.
Double-cliquez pour ouvrir la clé netsvcs.
Dans le champ Données de la valeur :
Ajoutez BITS et WUAUSERV à la liste des services.
Cliquer sur OK.
Quittez le Registre.
Redémarrez le système.

Bref, je reviens de loin.
J’ai remis tout ça en ordre et nous sommes le 4 Août 2008, tout semble fonctionner correctement.

Category: Un peu de technique  Tags:  Comments off